Problem nach Installation

  • Ja tatsächlich.


    Deaktiviere ich aber unter Konfiguration --> push++ "https" schalte also auf http, erhalte ich folgenden Fehler in der Konsole:

    Code
    1. Mixed Content: The page at 'https://www.domain.tld/' was loaded over HTTPS, but attempted to connect to the insecure WebSocket endpoint 'ws://domain.tld/socket?userID=2&token=92e1e"xxx"e595d18706c35&hash=b6965d169"xxx"e1b36cce718c08fa32068496604'. This request has been blocked; this endpoint must be available over WSS.


    Erstgenannter Fehler wenn unter Konfiguration --> puss++ folgendes Eingegeben ist:

    wss://www.domain.tld/socket

    https://127.0.0.1:8082


    2ter Fehler bei

    ws://www.domain.tld/socket

    http://127.0.0.1:8082


    Stelle ich es ein wie in der Anleitung auf dem Screen also:

    wss://www.domain.tld/socket

    http://127.0.0.1:8082


    Erhalte ich folgende Meldung in der Konsole:

    Code
    1. VM1966:164 WebSocket connection to 'wss://domain.tld/socket?userID=2&token=deb930b24"xxx"eff6a460dc8c&hash=eb3ab02ccfdd27aec"xxx"1212081a12ed1c5ae3446089a4c765e96b' failed: Error during WebSocket handshake: Unexpected response code: 301


    Der Anleitung bin ich genau gefolgt.

  • Ja.


    Es steht

    ProxyPreserveHost on

    ProxyPass "/socket" "ws://127.0.0.1:8081"

    ProxyPassReverse "/socket" "ws://127.0.0.1:8081"


    Sowohl im http Bereich wie auch im https


    Ich habs auch mit

    ProxyPreserveHost on

    ProxyPass "/socket" "wss://127.0.0.1:8081"

    ProxyPassReverse "/socket" "wss://127.0.0.1:8081"


    Im https Bereich getestet. Schien Logisch für mich. Der Fehler blieb aber identisch

  • Code
    1. ProxyPreserveHost on
    2. ProxyPass "/socket" "wss://127.0.0.1:8081"
    3. ProxyPassReverse "/socket" "wss://127.0.0.1:8081"

    Nein, dort muss ws, und nicht wsshin, da der Interne traffic vom Apache zum Push++ Server nicht verschlüsselt ist, dafür ist der Apache später da :)

    Ich verwende auch eine permanente (301) Weiterleitung von http zu https

    Das sollte egal sein. Verwendest du so etwas wie Plesk oder ein anders CP für die Verwaltung des Apache?


    Hast du den Socket mit www. oder ohne eingetragen?

    Falls nein, mach dies bitte mal.

  • Das sollte egal sein. Verwendest du so etwas wie Plesk oder ein anders CP für die Verwaltung des Apache?

    Ja Plesk Onyx in der aktuellen Version. Da gibt es die einfache Möglichkeit unter Apache & nginx Settings unter --> Additional directives for HTTP und --> Additional directives for HTTPS die Angaben zu machen.


    Hast du den Socket mit www. oder ohne eingetragen?

    Falls nein, mach dies bitte mal.

    :thumbup: Das wars. Mit www schmeißt die Konsole nun keinen Fehler mehr. Also gleich mal testen obs funktioniert.


    Edit: Getestet und alles funktioniert wie es soll. Danke Cyperghost für die tatkräftige Hilfe

  • Cyperghost

    Hat das Thema geschlossen